FZU 1759 Super A^B mod C (欧拉降幂)

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,C<=1000000000,1<=B<=10^1000000).

Input
There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.
Output
For each testcase, output an integer, denotes the result of A^B mod C.
Sample Input
3 2 4
2 10 1000
Sample Output
1
24

欧拉降幂的裸题。
看下图这里写图片描述

对于这个题目因为B非常大,所以用数组存,同时降一层幂即可。
代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<map>
using namespace std;
typedef long long ll;
const int MAX = 1000010;
char str[MAX];
map<int,int> mp;
ll Quick_pow(ll x,ll n,ll Mod){
    ll res = 1;
    while(n > 0){
        if(n&1)
            res = res*x%Mod;
        x = x*x%Mod;
        n >>= 1;
    }
    return res;
}
int euler_phi(int n){
    int res = n;
    for(int i=2;i*i<=n;++i){
        if(n%i == 0){
            res = res/i*(i-1);
            while(n%i == 0)
                n/=i;
        }
    }
    if(n != 1)  res = res/n*(n-1);
    return res;
}
int main(void){
    ll A,C;
    while(scanf("%I64d%s%I64d",&A,str,&C) != EOF){
        ll v = 0;
        bool isok = false;
        int len = strlen(str);
        for(int i=0;i<len;++i){
            v = v*10+str[i]-'0';
            if(v >= C){//先判断是否比C大
                isok = true;
                break;
            }
        }
        ll res;
        if(isok){
            v = 0;
            int phC = euler_phi((int)C);
            for(int i=0;i<len;++i){
                v = v*10+str[i]-'0';
                v %= phC;
            }
            res = Quick_pow(A,v+phC,C);
        }
        else{
            res = Quick_pow(A,v,C);
        }
        printf("%I64d\n",res);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值