poj2411 Mondriaan's Dream(轮廓线dp)

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

题目大意:给出一个 nm n ∗ m 的矩形,然后用 12 1 ∗ 2 大小的骨牌去填充 nm n ∗ m 的这个矩形,问有多少种填充方法。

今天做了一道轮廓线dp的题,发现轮廓线真的是妙啊,虽然代码短但是比其他dp题难理解,细节也很多。至于这道题的题解可以去看蓝书,然后这篇博客也写的不错:http://blog.csdn.net/u013480600/article/details/19499899

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int n,m,cur;
long long dp[2][1<<13];

void update(int a,int b){
    if(b&(1<<m))dp[cur][b^(1<<m)]+=dp[cur^1][a];
}

int main()
{
    while(scanf("%d%d",&n,&m)){
        if(!n&&!m)break;
        memset(dp,0,sizeof(dp));
        cur=0;dp[0][(1<<m)-1]=1;
        for(int i=1;i<=n;i++)
          for(int j=1;j<=m;j++){
            cur^=1;
            memset(dp[cur],0,sizeof(dp[cur]));
            for(int k=0;k<(1<<m);k++){
                if(k&(1<<(m-1)))update(k,k<<1);
                if(i>1&&!(k&(1<<(m-1))))update(k,(k<<1)^1^(1<<m));
                if(j>1&&!(k&1)&&k&(1<<(m-1)))update(k,(k<<1)^3);
            }
          }
        printf("%lld\n",dp[cur][(1<<m)-1]);
    }
    return 0;
}

其实这道题也可以用状压做,但是要比轮廓线慢很多。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值