ZOJ 2747 Windows Message Queue

Windows Message Queue

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!


Author:  ZHOU, Ran
Source:  Zhejiang University Local Contest 2006, Preliminary
Submit     Status

ACcode:

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rds(x) scanf("%s",x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define ll long long int
#define maxn 60000+5
#define mod 1000000007
#define INF 0x3f3f3f3f //int×î´óÖµ
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
struct node{
    char name[100];
    int para;
    int pri,t;
}p[maxn];
int heap[maxn];
int top,used;
inline void swap(int &a,int &b){
    a^=b^=a^=b;
}
int cmp(int a,int b){
    if(p[a].pri<p[b].pri)
        return -1;
    if(p[a].pri>p[b].pri)
        return 1;
    if(p[a].t<p[b].t)
        return -1;
    if(p[a].t>p[b].t)
        return 1;
    return 0;
}
int main(){
    string s;
    used=top=0;
    int cnt=0;
    while(cin>>s){
        if(s=="GET"){
            if(top){
                printf("%s %d\n",p[heap[1]].name,p[heap[1]].para);
                int pos=1;
                heap[pos]=heap[top--];
                while(pos*2<=top){
                    int t=pos*2;
                    if(t<top&&cmp(heap[t+1],heap[t])<0)
                        ++t;
                    if(cmp(heap[t],heap[pos])<0){
                        swap(heap[t],heap[pos]);
                        pos=t;
                    }else
                        break;
                }
            }
            else
                printf("EMPTY QUEUE!\n");
        }
        else {
            rds(p[used].name);
            rd2(p[used].para,p[used].pri);
            p[used].t=cnt++;
            int pos=++top;
            heap[pos]=used++;
            while(pos>1){
                int t=pos/2;
                if(cmp(heap[t],heap[pos])>0){
                    swap(heap[t],heap[pos]);
                    pos=t;
                }else
                    break;
            }
        }
    }
    return 0;
}
/**
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
**/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值