HDU 1509 Windows Message Queue(重载运算符、优先队列的应用)

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
Input
There’s only one test case in the input. Each line is a command, “GET” or “PUT”, which means getting message or putting message. If the command is “PUT”, there’re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
Output
For each “GET” command, output the command getting from the message queue with the name and parameter in one line. If there’s no message in the queue, output “EMPTY QUEUE!”. There’s no output for “PUT” command.
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
Sponsor

//优先队列的应用

#include<stdio.h>
#include<iostream>
#include<queue>
#include<string>
#include<string.h>
using namespace std;
/*
struct node{
    char name[10];
    int k;     //代表入队的顺序
    int x;
    int value;  //优先值
    bool operator < (const node &p) const{
        if(value==p.value)
            return k > p.k;
        return value > p.value;
    }
};*/
struct node{
    char name[10];
    int k;
    int x;
    int value;
    friend bool operator < (struct node a,struct node b){   //友元函数
        if(a.value==b.value)
            return a.k > b.k;
        return a.value > b.value;
    }
};
priority_queue <node> q;
int main()
{
    char str[10];
    int k1=1;
    while(scanf("%s",str)!=EOF)
    {
        if(strcmp(str,"GET")==0){
            if(!q.empty()){
                cout<<q.top().name<<" "<<q.top().x<<endl;
                q.pop();
            }
            else
                cout<<"EMPTY QUEUE!"<<endl;
        }
        else{
            struct node t;
            cin>>t.name>>t.x>>t.value;
            t.k = k1++;
            q.push(t);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

葛济维的博客

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值