WoodenSticks(区间贪心类题目)

Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 


(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 


You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2). 
 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 
 
Output
The output should contain the minimum setup time in minutes, one per line. 
 
Sample Input


4 9 5 2 2 1 3 5 1 4 

2 2 1 1 2 2 

1 3 2 2 3 1 
 
Sample Output
2
1

这个题目是贪心类题目,算是做的第二个贪心类题目了。

思路就是先把w1或者l1其中的一个从小到大排列。我是把w从小到大排列的,但是这其中可能有w相同时l也应该从小到大排列。

排完之后刚开始我只是找了一组1分钟的,意思是其他满足上述条件的一组就是一分钟了。所以那些测试数据都也能通过,但是就是wrong answer,后来找到了原因改了代码终于对了。  好、还是请大神们指点。

#include <cstdio>
#include <iostream>
#include <algorithm>


using namespace std;


int main()
{
    int a;
    int x[10001][2];
    scanf("%d",&a);
    while(a--)
    {
        int b;
        scanf("%d",&b);
        for (int number=0;number<b;number++)
        {
            scanf("%d %d",&x[number][0],&x[number][1]);
        }
        int Mix,temp;
        for (int number1=0;number1<b;number1++)
        {
            Mix=number1;
            for (int number2=number1+1;number2<b;number2++)
            {
               if (x[Mix][1]>x[number2][1])
                    Mix=number2;
            }
            if (Mix!=number1)
            {
                temp=x[Mix][1];
                x[Mix][1]=x[number1][1];
                x[number1][1]=temp;
                temp=x[Mix][0];
                x[Mix][0]=x[number1][0];
                x[number1][0]=temp;
            }
        }
        for (int number=0;number<b-1;number++)
        {
            if (x[number][1]==x[number+1][1])
            {
                if (x[number][0]>x[number+1][0])
                {
                    temp=x[number][0];
                    x[number][0]=x[number+1][0];
                    x[number+1][0]=temp;
                }
            }
        }
        int Count=0,Max;
        for (int number1=0;number1<b;number1++)
        {
             if (x[number1][0]!=-1)
             {
                 Count++;
                 Max=x[number1][0];
                 for (int number2=number1+1;number2<b;number2++)
                 {
                     if (x[number2][0]!=-1)
                     {
                         if (x[number2][0]>=Max)
                         {
                             Max=x[number2][0];
                             x[number2][0]=-1;
                         }
                     }
                 }
             }
        }
        printf("%d\n",Count);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值