文章目录
Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB
A1132 Cut Integer (20point(s))
Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2^31 ). It is guaranteed that the number of digits of Z is an even number.
Output Specification:
For each case, print a single line Yes if it is such a number, or No if not.
Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No
Code
#include <bits/stdc++.h>
using namespace std;
int main(){
int n;
string s;
cin>>n;
for(int i=0;i<n;i++){
cin>>s;
string s1=s.substr(0,s.length()/2),s2=s.substr(s.length()/2,s.length()/2);
long long a=stol(s1),b=stol(s2),c=stol(s);
if(a==0||b==0||c%(a*b)!=0) printf("No\n");
else printf("Yes\n");
}
return 0;
}
Analysis
-给定一个位数为偶数的的整数z。若把z按位数平均分成两部分得到a和b后,若z是(a*b)的非零整数倍,则输出Yes,否则输出No。
-注意分子为零的情况。