【PAT】A1023. Have Fun with Numbers (20)

Description:
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

 

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

 

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

 

Sample Input:
1234567899


Sample Output:
Yes
2469135798

//NKW 甲级练习题1034
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <vector>
using namespace std;
char num[21];
vector<int> vi;
int htable[10], flag = 1;
int main(){
	memset(htable, 0, sizeof(htable));
	scanf("%s", num);
	for (int i = 0; i < strlen(num); i++){
		htable[num[i] - '0']++;
		vi.push_back((num[i] - '0') * 2);
	}
	for (int i = vi.size()-1; i > 0; i--){	//这里我们不对vi[0]进位,因为如果vi[0]需要进位,那么结果一定为“No”
		if (vi[i] / 10){		//由于本题只是double,所以在一个vi[i]中不会出现三位数
			vi[i - 1] += vi[i] / 10;
			vi[i] = vi[i] % 10;
		}
		htable[vi[i]]--;
	}
	if (vi[0] / 10){			//如果最高位需要进位,即double后数字边长一位
		printf("No\n");
		for (int i = 0; i < vi.size(); i++)
			printf("%d", vi[i]);
		printf("\n");
		system("pause");
		return 0;
	}
	htable[vi[0]]--;
	for (int i = 0; i < vi.size(); i++){
		if (htable[vi[i]]){
			printf("No\n");
			flag = 0;
			break;
		}
	}
	if (flag)
		printf("Yes\n");
	for (int i = 0; i < vi.size(); i++)
		printf("%d", vi[i]);
	printf("\n");
	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值