文章目录
Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB
1149 Dangerous Goods Packaging (25 point(s))
When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.
Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10^4 ), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.
Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:
K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.
Output Specification:
For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.
Sample Input:
6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
Sample Output:
No
Yes
Yes
Code
#include <iostream>
#include <stdio.h>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;
map<int, vector<int> > mvi;
int main(){
int n, m, k, a, b;
cin >> n >> m;
for(int i = 0; i < n; i++){
cin >> a >> b;
mvi[a].push_back(b);
mvi[b].push_back(a);
}
for(int i = 0; i < m; i++){
cin >> k;
bool flag1 = false;
vector<int> ha(100000, 0), vi(n);
for(int j = 0; j < k ; j++){
cin >> vi[j];
for(int l = 0; l < mvi[vi[j]].size(); l++){
ha[mvi[vi[j]][l]] = 1;
}
}
for(int j = 0; j < vi.size(); j++){
if(ha[vi[j]] == 1){
flag1 = true;
break;
}
}
if(flag1 == true) printf("No\n");
else printf("Yes\n");
}
return 0;
}
Analysis
-已知n对不能放在一起的物品。并给出m组放在一起的物品。
-判断每组物品放在一起是否安全。
-一开始用map存放与某物品不能放在一起的所有物品。在每组中判断时,每读入一个物品的ID,将对应的所有不能放在一起的物品在ha数组中标记。全部读完后,查看ha数组每一个读入物品ID位置的值,只要有一个为1,就表示该组物品放在一起有危险。