Anniversary party (第一道树状dp)

 

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 

 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

 

 

Output

Output should contain the maximal sum of guests' ratings.

 

 

Sample Input

 

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

 

 

Sample Output

 

题意:在一个有根树上每个节点有一个权值,每相邻的父亲和孩子只能选择一个,问怎么选择总权值之和最大。

思路:

树形dp的常规入门题:设dp[i][0]表示:当前这个点不选,dp[i][1]表示当前这个点选择的最优解。

转移方程:dp[cur][0]+=max(dp[son][1],dp[son][0]);//当前这个点不选,那他的孩子可选可不选,取 
最大的。 
dp[cur][1]+=dp[son][0]//当前这点选择,那他的孩子就不能选择。
 

唯一个问题是我一开始用数组存树,就是f[b]=a表示b的父亲是a ,然后寻找儿子的时候就从头到尾遍历On, 总是TLE,,,,气得我,又去网上看了别人用得vector,遂ac

另外,为什么这个hdu的题意中看不出是多case题啊,,,无语辽。。

AC代码:

#include<iostream>
#include<cstring>
#include<vector> 
using namespace std;
vector<int> e[6005];
int n;
int dp[6005][3],flag[6005];
void dfs(int root)
{
	for(int i=0;i<e[root].size();i++) //dfs它的所有孩子 
	{
		int son=e[root][i];
		dfs(son);
		dp[root][1]+=dp[son][0];
		dp[root][0]+=max(dp[son][0],dp[son][1]);
	}
}
int main()
{
	int l,k,i;
	int root;
	while(scanf("%d",&n)!=EOF)
	{
	memset(flag,0,sizeof(flag));
	for(i=1;i<=n;i++)
	{
	scanf("%d",&dp[i][1]);
	dp[i][0]=0;
	e[i].clear();
	}
	while(~scanf("%d%d",&l,&k)&&l&&k)
	{
		e[k].push_back(l); //l加入k的子节点的容器 
		flag[l]=1;       //标记为有子节点的元素 
	}
	for(i=1;i<=n;i++)
	{
		if(flag[i]==0) //找到根节点(没有子节点) 
		{
			root=i;
			break;
		}
	}
	dfs(root);
	int maxx=0;
	printf("%d\n",max(dp[root][1],dp[root][0]));
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值