HDOJ 2899 Strange fuction(二分,求导。。)

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4287    Accepted Submission(s): 3092


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
 
 
求函数x在区间[0,100]内的最小值,可以把y看成一个实数。用到了求导,二次求导。表示数学很渣,高数课也没怎么去,高中学的也全忘光了。不太懂啊。。。。。
 
求导结束,判断单调性。是一个凹函数,可以用二分法求极值。
 
具体代码如下:
 
#include<stdio.h>
#include<math.h>
#define res 1e-8
double y;

double g(double x)
{
	return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;//一次求导 
}

double f(double x)
{
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}

int main()
{
	int t;
	double l,r,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		if(g(100.0)-y<=0)/*g(x)为递增的,-y后如果为0,则整个f(x)为递减*/  
		{
			printf("%.4lf\n",f(100.0));
			continue;
		}
		 /*算二次导数,可知f(x)为凹函数,存在最小值,然后二分求解*/  
		l=0;r=100;
		while(r-l>=res)
		{
			m=(r+l)/2;
			if(g(m)-y<0)
			   l=m;
			else
			   r=m;
		}
		printf("%.4lf\n",f(m));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值