HDU4653 Strongly connected

Strongly connected

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2464    Accepted Submission(s): 1029


Problem Description
Give a simple directed graph with N nodes and M edges. Please tell me the maximum number of the edges you can add that the graph is still a simple directed graph. Also, after you add these edges, this graph must NOT be strongly connected.
A simple directed graph is a directed graph having no multiple edges or graph loops.
A strongly connected digraph is a directed graph in which it is possible to reach any node starting from any other node by traversing edges in the direction(s) in which they point. 
 

Input
The first line of date is an integer T, which is the number of the text cases.
Then T cases follow, each case starts of two numbers N and M, 1<=N<=100000, 1<=M<=100000, representing the number of nodes and the number of edges, then M lines follow. Each line contains two integers x and y, means that there is a edge from x to y.
 

Output
For each case, you should output the maximum number of the edges you can add.
If the original graph is strongly connected, just output -1.
 

Sample Input
  
  
3 3 3 1 2 2 3 3 1 3 3 1 2 2 3 1 3 6 6 1 2 2 3 3 1 4 5 5 6 6 4
 

Sample Output
  
  
Case 1: -1 Case 2: 1

Case 3: 15

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<stack>
#include<vector>
using namespace std;
const int maxm=100005;
typedef struct
{
	int x,y;
}H;
H a[maxm];
int num[maxm],belong[maxm],vis[maxm],low[maxm],dfn[maxm],id,sum;
int g[maxm],f[maxm];
stack<int>s;
vector<int>v[maxm];
void tarjian(int x);
int main()
{
	int n,i,j,k,m,t,x,y,cas=1;
	scanf("%d",&t);
	while(t--)
	{
		while(!s.empty())
			s.pop();
		memset(vis,0,sizeof(vis));
		memset(num,0,sizeof(num));
		memset(low,0,sizeof(low));
		memset(dfn,0,sizeof(dfn));
		memset(g,0,sizeof(g));
		memset(f,0,sizeof(f));
		sum=1;id=1;
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			v[i].clear();
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			a[i].x=x;
			a[i].y=y;
			v[x].push_back(y);
		}
		for(i=1;i<=n;i++)
		{
			if(!dfn[i])
				tarjian(i);
		}
		for(i=1;i<=m;i++)
		{
			if(belong[a[i].x]!=belong[a[i].y])
			{
				g[belong[a[i].y]]++;
				f[belong[a[i].x]]++;
			}
		}
		int ans=10000000,rev;
		for(i=1;i<sum;i++)
		{
			if(f[i]==0 || g[i]==0)
			{
				if(num[i]<ans)
					ans=num[i];	
			}
		}
		//printf("%d\n",sum);
		x=(long long)(n*(n-1))-m-(long long)(ans*(n-ans));
		printf("Case %d: ",cas++);
		if(ans==10000000 || sum<=2)
			printf("-1\n");
		else
			printf("%d\n",x);
	}
	return 0;
}
void tarjian(int x)
{
	int i,j;
	s.push(x);low[x]=dfn[x]=id++;vis[x]=1;
	for(j=0;j<v[x].size();j++)
	{
		int xx=v[x][j];
		if(!dfn[xx])
		{
			tarjian(xx);
			low[x]=min(low[x],low[xx]);
		}
		else if(vis[xx])
			low[x]=min(low[x],dfn[xx]);
	}
	if(dfn[x]==low[x])
	{
		while(s.size())
		{
			int xx=s.top();s.pop();
			vis[xx]=0;
			num[sum]++;
			belong[xx]=sum;
			if(xx==x)
				break;
		}
		sum++;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值