《动态规划》— HDU 2639 Bone Collector II(01背包+第K有解)

本文介绍了一个基于动态规划的ACM竞赛题目——Bone Collector II。不同于寻找最大价值,任务是找到第K个最大的背包组合总价值。当不同价值的骨骨头数少于K时,输出0。题目包含多组测试用例,给出了每组测试的物品价值和体积,并需求解第K个最大总价值。
摘要由CSDN通过智能技术生成

Bone Collector II

 

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4662    Accepted Submission(s): 2429

 

 

Problem Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

 

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 231).

 

 

Sample Input

 

3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1

 

 

Sample Output

 

12 2 0

 

 

Author

teddy

 

 

Source

百万秦关终属楚

 

 

Recommend

teddy   |   We have carefully selected several similar problems for you:  2159 1203 2955 1114 3033 

 

 

第k大 背包问题,就是开多一维去记录前k大的最优值,即p[v][k]表示装了v体积的东西获得第k大的价值网上有个比喻用得好,要计算整个年级的前n名,可以拿每班的前n名出来排序包也是这样,数组a[], b[]来保存 p[j - w[i]][1 -> k] + v[i] , 以及p[j][1 - >k] 这些值然后将两个数组里面的值按大到小的顺序重新写入 p[j][1 -k]中这样就更新了p[i]数组了
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1005

int dp[maxn][35],v[105],w[105],A[35],B[35];

int main(){
    int n,V,t,k;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&n,&V,&k);
        for(int i=1;i<=n;i++)
            scanf("%d",v+i);
        for(int i=1;i<=n;i++)
            scanf("%d",w+i);
            
        memset(dp,0,sizeof(dp));   //初始化 

        int a,b,c,kk;

        for(int i=1;i<=n;i++)
            for(int j=V;j>=w[i];j--){
                for(kk=1;kk<=k;kk++){
                    A[kk]=dp[j][kk];
                    B[kk]=dp[j-w[i]][kk]+v[i];
                }
                A[kk]=B[kk]=-1;
                a=b=c=1;

                while(c<=k&&(A[a]!=-1||B[b]!=-1)){
                    if(A[a]>B[b])
                        dp[j][c]=A[a++];
                    else
                        dp[j][c]=B[b++];
                    if(dp[j][c]!=dp[j][c-1])
                        c++;
                }
            }
        printf("%d\n",dp[V][k]);
    }
    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值