hdu Bone Collector II


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2[sup]31[/sup]).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0


背包,第k大费用背包问题






#include<iostream>
#include<cmath>
#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<string.h>
#define INF 2000000;
using namespace std;
int dp[1100][100];
int vis[1000],cs[10000];
int cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,kt;
        scanf("%d%d%d",&n,&m,&kt);
        for(int i=0;i<n;i++)
            scanf("%d",&vis[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&cs[i]);
        memset(dp,0,sizeof(dp));
        int a[2*kt+10];
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            for(int j=m;j>=cs[i];j--)
            {
                for(int k=0;k<kt;k++)
                {
                    a[2*k]=dp[j-cs[i]][k]+vis[i];//背包大小为j的 装或者不装都保存下来
                    a[2*k+1]=dp[j][k];
                }
                sort(a,a+2*kt,cmp);
                dp[j][0]=a[0];
                int h=1;
                for(int k=1;k<kt;k++)//只取前k个
                {
                    while(1)
                    {
                        if(h>=2*kt||a[h]!=a[h-1])
                            break;
                         h++;
                    }
                    if(h>=2*kt||a[h]==0)
                        break;
                    dp[j][k]=a[h];
                    h++;
                }
            }
        }

        printf("%d\n",dp[m][kt-1]);
    }


}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值