hdu2639Bone Collector II (01背包,求第k优解)

Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1

Sample Output
  
  
12 2 0

题目意思是:在一个背包容量为V,每种bone的所占容量和价值,它们有很多种组合,条件是每种组合所占容量不能超出V,每种组合的总价值按严格递减序列,求出第k大值。

下面是引用网上的话也行形象:

如果我想知道学年最高分,那么,我只要知道每个班级的最高分,然后统计一遍就可以了。如果我想知道学年前十呢?我必须要知道每个班的前十名。大家在心里模拟一下,对,这就是本题核心的算法。两种决策,就可以看作这个学年只有两个班。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1010
struct nn
{
    int usev,w;
}bone[N];
int dp[N][35],V,K;
int cmp(int a,int b){return a>b;}
int max(int a,int b){return a>b?a:b;}
void zeroonepack(int use,int w)
{
    int b[70],bn,k,i;
    for(int v=V;v>=use;v--)
    {
        for( bn=0,k=0;k<K;k++)
        {
            b[bn++]=dp[v][k];
            b[bn++]=dp[v-use][k]+w;
        }
        sort(b,b+bn,cmp);
        k=0;dp[v][0]=b[0];
            for(i=1;i<bn&&k<K;i++)
            if(dp[v][k]!=b[i])
                   dp[v][++k]=b[i];
        }
    }
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&V,&K);
        for(int i=1;i<=n;i++)
        scanf("%d",&bone[i].w);
        for(int i=1;i<=n;i++)
        scanf("%d",&bone[i].usev);
        for(int i=0;i<=V;i++)
        for(int j=0;j<=K;j++)
            dp[i][j]=0;
        for(int i=1;i<=n;i++)
        zeroonepack(bone[i].usev,bone[i].w);
        printf("%d\n",dp[V][K-1]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值