Tempter of the Bone

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES


题意:

从S走到D ,要求在t 时刻刚好到达,只能从上下左右四个方向走,每走一格花费一个时刻,“#”不能走

#include<stdio.h>
#include<string.h>
using namespace std;
char map[10][10];
int book[10][10];
int n,m,t,sx,sy,ex,ey,sum,flag;
int abs(int a){
    return a>0?a:-a;
}
void Dfs(int x,int y,int step){
    if(flag) return;
    if(x==ex&&y==ey&&t==step){
        flag=1;
        return;
    }
    //奇偶减枝
    int smin=abs(ex-x)+abs(ey-y);//此时到终点的最短距离
    int ok=t-step;// 到终点还需走到步数
    if((ok+smin)%2!=0||smin>ok) return ;//如果还需偶数步到达,最短距离是奇数 则不可能到达
    int next[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
    int i;
    for(i=0;i<4;i++){
        int tx=x+next[i][0];
        int ty=y+next[i][1];
        if(tx<0||ty<0||tx==n||ty==m)
            continue;
        if(book[tx][ty]==0&&map[tx][ty]!='X'){
            book[tx][ty]=1;
            Dfs(tx,ty,step+1);
            book[tx][ty]=0;
        }
    }
}
int main(){
    while(scanf("%d%d%d",&n,&m,&t)!=EOF){
        if(n==0&&m==0&&t==0) break;
        getchar();
        memset(map,0,sizeof(map));
        memset(book,0,sizeof(book));
        sum=0;
        int i,j;
        for(i=0;i<n;i++){
            for(j=0;j<m;j++){
               scanf("%c",&map[i][j]);
               if(map[i][j]=='S'){
                sx=i;
                sy=j;
               }
               if(map[i][j]=='D'){
                ex=i;
                ey=j;
               }
               if(map[i][j]=='X')
                    sum++;
            }
            getchar();
        }
        if(n*m-sum-1<t){
            printf("NO\n");
            continue;
        }
        flag=0;
        book[sx][sy]=1;
        Dfs(sx,sy,0);
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值