poj 2503(scanf和gets读取字符串)

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 29101 Accepted: 12590

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source


水题。直接用map水过。

注意C的输入,用scanf如果读到文件末尾,会返回EOF。因此要用while (EOF != scanf("%s", str)) {}格式。 scanf读到空格就会认为是一个str(%s)。

而gets如果读到文件末尾,会返回NULL指针。因此要用while(gets(str)) {} 格式。gets(会一直读到\n换行符才会认为是一个str(%s)。

char * strchr(str, 'x') 会返回str中x字符出现的第一个位置的指针

strncpy(a, str, x - str);  最多读取n个字符

提交记录:

1、AC

#include<iostream>
#include<fstream>
#include<algorithm>
#include<assert.h>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<map>
#include<deque>
#include<list>
#include<vector>
#define oo 0x3f3f3f3f
#define MAXN 25
using namespace std;
map<string, string> m;
int main()
{
    char str[40], a[40], b[40];
    string aa, bb;
    char * x;
    int step = 0;
    while (gets(str)) {
        if (step == 0 && 0 == strcmp(str, "")) {step = 1; continue;}
        if (step == 0) {
            x = strchr(str, ' ');
            strncpy(a, str, x - str);
            a[x-str] = 0;
            strcpy(b, x+1);
            aa.assign(a);
            bb.assign(b);
            m[bb] = aa;
        }
        else {
            aa.assign(str);
            if (m.find(aa) == m.end()) {
                printf("eh\n");
            }
            else
                printf("%s\n", m[aa].c_str());
        }
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值