Greatest Common Increasing Subsequence

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

题意:求最大公共上升子序列的长度。

思路:二维数组dp内存的是最长上升子序列的长度,dp[i][j],表示数组a的前i项,数组b的前j项的最长公共上升子序列,在一层for循环内每次满足条件就更新maxx的值,在外层for循环更新sum的值,最后输出即可,代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long dp[550][550],a[550],b[550];
int main()
{
    long long i,j,T,n1,n2,sum,maxx;
    scanf("%lld",&T);
    while(T--)
    {
        sum=0;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(dp,0,sizeof(dp));
        scanf("%lld",&n1);
        for(i=1; i<=n1; i++)
            scanf("%lld",&a[i]);
        scanf("%lld",&n2);
        for(i=1; i<=n2; i++)
            scanf("%lld",&b[i]);
        for(i=1; i<=n1; i++)
        {
            maxx=0;
            for(j=1; j<=n2; j++)
            {
                dp[i][j]=dp[i-1][j];
                if(b[j]<a[i]&&maxx<dp[i-1][j])
                    maxx=dp[i-1][j];
                if(a[i]==b[j])
                    dp[i][j]=++maxx;
            }
         if(sum<maxx)
            sum=maxx;
        }
        printf("%lld\n",sum);
        if(T)
            printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值