HDU1423 Greatest Common Increasing Subsequence(最长公共递增子序列)

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
Output
output print L - the length of the greatest common increasing subsequence of both sequences.
Sample Input
1

5
1 4 2 5 -12
4
-12 1 2 4
Sample Output
2

题意:在找出最长公共子序列的基础上加一个条件————找出最长递增公共子序列 的长度

解题思路:
模拟下人脑的思路~

从第一个序列中的第一个数开始依次给第二个序列中的每个数比较,在第二个序列的每个数都记录下每次比较后的序列的最大长度

dp[]表示到第i个数时序列的最大长度
k用来记录 判断每个数之前的序列的最大长度

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
    int t,n,m,sum;
    int a[5200],b[5200],dp[5200];//dp表示到当前数字使公共序列的长度最长是多少 

    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(int j=1;j<=m;j++)
            scanf("%d",&b[j]);

        sum=0;
        for(int i=1;i<=n;i++)
        {
            int k=0;//在判断每个数时k将每次之前的最大长度记录下来带到这个数面前,
                    //如果这个数在a,b序列中同时存在并且可以使长度+1,则更新这个数的dp值 
            for(int j=1;j<=m;j++)
            {
                if(a[i]==b[j]&&dp[j]<k+1) dp[j]=k+1;//如果这个数两个序列都存在并且能使长度+1 
                else if(a[i]>b[j])//k值记录下本次循环到这个数前最大的长度 
                {
                    if(dp[j]>k) k=dp[j];
                }
                sum=max(sum,dp[j]);//sum记录下最长长度 
            }
        }
        printf("%d\n",sum);
        if(t) printf("\n");
    }
    return 0;
}

蟹蟹小淑女学长~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值