HDU 6029 Graph Theory【水题】

20 篇文章 0 订阅

Graph Theory

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 448    Accepted Submission(s): 216


Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called ``Cool Graph'', which are generated in the following way:
Let the set of vertices be {1, 2, 3, ...,  n }. You have to consider every vertice from left to right (i.e. from vertice 2 to  n ). At vertice  i , you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to  i1 ).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ''Cool Graph'' has perfect matching. Please write a program to help him.
 

Input
The first line of the input contains an integer  T(1T50) , denoting the number of test cases.
In each test case, there is an integer  n(2n100000)  in the first line, denoting the number of vertices of the graph.
The following line contains  n1  integers  a2,a3,...,an(1ai2) , denoting the decision on each vertice.
 

Output
For each test case, output a string in the first line. If the graph has perfect matching, output ''Yes'', otherwise output ''No''.
 

Sample Input
  
  
3 2 1 2 2 4 1 1 2
 

Sample Output
  
  
Yes No No
 

Source

问题

有n个点,1表示当前点与之前所有点连一条边,2表示不动,问通过选出其中的某些边,能否使所有的点都能够有一个点与其配对。

思路:
用cnt表示前面有多少个未配对的点,
如果前面有未配对的点则,若操作为1,,则cnt--,若操作为2则cnt++
如果前面所有的点都匹对成功则,若操作为1,,则cnt=1(因为前面没有点与其配对),若操作为2则cnt++

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<map>
#include<set>
#include<stack>
#include<bitset>
#include<numeric>
#include<vector>
#include<string>
#include<iterator>
#include<cstring>
#include<ctime>
#include<functional>
#define INF 0x3f3f3f3f
#define ms(a,b) memset(a,b,sizeof(a))
#define pi 3.14159265358979
#define mod 1000000007
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;

typedef pair<int, int> P;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 100010;

int n, a[maxn];

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int cnt = 1;
		scanf("%d", &n);
		for (int i = 2; i <= n; i++)
		{
			scanf("%d", a + i);
		}
		if (n % 2 != 0) puts("No");
		else
		{
			for (int i = 2; i <= n; i++)
			{
				if (a[i] == 1)
				{
					if (cnt == 0) cnt = 1;
					else cnt--;
				}
				else cnt++;
			}
			if (cnt > 0) puts("No");
			else puts("Yes");
		}
	}
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值