1022 Digital Library (30分)
A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
4
) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:
Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.
After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:
1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.
Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
解题
构建map,存放 key(要查询的关键词):value(书本ID),若关键词和出版社和title名称可能重复,需要各构建一个map,本题不重复,所以构建一个map即可。
难点:输入输出
1.输入一行string
getline(cin,title);
2.输入%d后,需要读入\n进行读入换行;
cin>>ID;
cin.get(); //换行符读掉
//getchar();
cin.get()和getchar()两者都行;
3.读入一整行关键字,按空格分隔放入关键字数组中
keywords.clear();
string line,t; //读入keyword
getline(cin,line);
stringstream linestream;
linestream.str(line);
while(linestream>>t)
keywords.push_back(t);
stringstream输入流,linestream.str(line),复制构造函数,用>>将linestream内的string逐个赋给keywords;
或者挨个读入key,当读入下一个char为\n时,停止key的读入;
while(cin >> _key){ //*
key[_key].insert(id);
if(getchar()=='\n') break;
}
因为用vector保存ID,所以需要先排序,再进行查询操作;
如果用set保存ID,则用迭代器遍历输出即可,set默认从小到大输出!
#include<iostream>
#include<unordered_map>
#include<vector>
#include<cstring>
#include<sstream>
#include<algorithm>
using namespace std;
int N,Q;
unordered_map<string,vector<int>> library;
void input()
{
cin>>N;
int ID;
string title; //cin.get() or getline(cin,) or cin.getline()
string author;
vector<string> keywords;
string publisher; // 80 characters
string pubyear;
for(int i=0;i<N;i++)
{
cin>>ID;
cin.get(); //换行符读掉
getline(cin,title);
getline(cin,author);
keywords.clear();
string line,t; //读入keyword
getline(cin,line);
stringstream linestream;
linestream.str(line);
while(linestream>>t)
keywords.push_back(t);
getline(cin,publisher);
cin>>pubyear;
//读入后放入map中
library[title].push_back(ID);
library[author].push_back(ID);
for(string i :keywords)
{
library[i].push_back(ID);
}
library[publisher].push_back(ID);
library[pubyear].push_back(ID);
}
//对每个排序
for(auto i=library.begin();i!=library.end();i++)
sort(i->second.begin(),i->second.end());
//读问题
cin>>Q;
cin.get(); //读掉换行符
int num;
string ques;
for(int i=0;i<Q;i++){
scanf("%d: ",&num);
getline(cin,ques);
cout<<num<<": "<<ques<<endl;
if(!library[ques].empty())
for(int id:library[ques])
printf("%07d\n",id);
else cout<<"Not Found"<<endl;
}
}
int main()
{
input();
}
易错点
输出时要输出7位id,少的要补0,或者用string保存ID,就直接输出即可;
存放keywords的vector每次都要清空!