BIT2014级软件学院程序设计-09 Easier Done Than Said

Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.
It cannot contain three consecutive vowels or three consecutive consonants.
It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'. 

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input

The input consists of one or more potential passwords, one per line. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input

a

tv

ptoui

bontres

zoggax

wiinq

eep

houctuh

Sample Output

<a> is acceptable.

<tv> is not acceptable.

<ptoui> is not acceptable.

<bontres> is not acceptable.

<zoggax> is not acceptable.

<wiinq> is not acceptable.

<eep> is acceptable.

<houctuh> is acceptable.

 

水题,模拟判断就行

#include<stdio.h>
#include<string.h>
#define maxn 100
char ch[maxn];
int yuan[maxn];//position
int check_yl(int i)
{
    if (i == 0)
    {
        if (yuan[i] > 2)
            return 1;
    }
    if (i >= 2)
    {
        if (yuan[i] == (yuan[i - 1] + 1) && yuan[i] == (yuan[i - 2] + 2))
            return 1;
    }
    if (i > 0)
    {
        if (yuan[i] - yuan[i - 1] > 3)
            return 1;
    }
    return 0;
}
int check_lian(int i)
{
    if (ch[i] == ch[i - 1] && ch[i] != 'e'&&ch[i] != 'o')
        return 1;
    return 0;
}
int check_yuan(char k)
{
    if (k == 'a' || k == 'e' || k == 'i' || k == 'o' || k == 'u')
        return 1;
    return 0;
}
int main()
{
    int i, j, len,flag1,tmp,flag2;
 
    while (scanf("%s", ch) != EOF)
    {
        memset(yuan,0,sizeof(yuan));
        tmp = 0;
        len = strlen(ch);
        flag1=0;flag2=0;
        for (i = 0;i < len;i++)
        {
            if (check_yuan(ch[i]))
            {
                flag1 = 1;
                yuan[tmp++] = i;
            }
            if (check_lian(i))
            {
                flag2 = 1;
            }
        }
        for (i =0;i < tmp;i++)
        {
            if (check_yl(i))
            {
                flag2 = 1;break;
            }
        }
        tmp--;if (len - yuan[tmp] >= 4)
            flag2 = 1;
 
 
 
        if (flag2 == 0 && flag1 == 1)
            printf("<%s> is acceptable.\n", ch);
        else printf("<%s> is not acceptable.\n", ch);
    }
}
//0123456


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值