PAT-A1073/B1024 Scientific Notation/科学计数法 题目内容及题解

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

科学计数法是科学家用来表示很大或很小的数字的一种方便的方法,其满足正则表达式 [+-][1-9].[0-9]+E[+-][0-9]+,即数字的整数部分只有 1 位,小数部分至少有 1 位,该数字及其指数部分的正负号即使对正数也必定明确给出。

现以科学计数法的格式给出实数 A,请编写程序按普通数字表示法输出 A,并保证所有有效位都被保留。

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

每个输入包含 1 个测试用例,即一个以科学计数法表示的实数 A。该数字的存储长度不超过 9999 字节,且其指数的绝对值不超过 9999。

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

对每个测试用例,在一行中按普通数字表示法输出 A,并保证所有有效位都被保留,包括末尾的 0。

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

解题思路

  1. 用字符串形式读取科学计数法数字;
  2. 读取其中的有效数字;
  3. 读取指数;
  4. 科学计数法表示为字符形式的普通数字,输出并返回零值。

代码

#include<stdio.h>
#define maxn 10010
char num[maxn],frac[maxn];

int main(){
    int i,fnum;
    int exp=0,zf;
    fgets(num,maxn,stdin);
    fnum=0;
    if(num[0]=='-'){
        printf("-");
    }
    for(i=1;i<maxn;i++){
        if(num[i]=='.'){
            continue;
        }
        if(num[i]=='E'){
            break;
        }
        frac[fnum++]=num[i];
    }
    i++;
    if(num[i]=='+'){
        zf=1;
    }else{
        zf=-1;
    }
    i++;
    while(num[i]>='0'&&num[i]<='9'){
        exp=exp*10+num[i]-'0';
        i++;
    }
    exp*=zf;
    if(exp<0){
        exp++;
        printf("0.");
        while(exp<0){
            printf("0");
            exp++;
        }
        printf("%s\n",frac);
    }else{
        i=0;
        while(i<=exp){
            if(i>=fnum){
                printf("0");
            }else{
                printf("%c",frac[i]);
            }
            i++;
        }
        if(i<=fnum-1){
            printf(".");
        }
        while(i<fnum){
            printf("%c",frac[i]);
            i++;
        }
        printf("\n");
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值