「1134」Vertex Cover

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than  ), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

where Nv​ is the number of vertices in the set, and  ’s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

Ω

顶点覆盖是一个顶点的集合,其定义是,如果图中任何一条边至少一个端点位于顶点集内则称该顶点集为一个顶点覆盖。给定图和几个顶点集,判断它们是否为顶点覆盖。

本质上是看顶点集中所有顶点关联边集的并集是否包含图中所有边。可以用一个vector<bool>进行标记,但这里我萌生了bitset的想法,用二进制位表示每个顶点关联的边集,然后对顶点集中所有顶点的边集二进制数取或运算,看最终二进制树中是否所有边位都为1,这也是求并集的一种方法。bitset是1位1bit,和bool不同的是可以直接进行位运算,不过bitset必须在编译期间就确定位数大小,因此不能用变量初始化位数。由于 ,因此直接开bitset<10000>,或运算结束后我们将其转换为字符串,取最后的m位检查是否全为1。


🐎

#include <iostream>
#include <bitset>
#include <vector>

using namespace std;

int main()
{
    int n, m, v, k, t, a, b;
    cin >> n >> m;
    vector<bitset<10000>> flag(n, 0);
    for (int i = 0; i < m; ++i)
    {
        cin >> a >> b;
        flag[a][i] = flag[b][i] = 1;
    }
    cin >> v;
    for (int i = 0; i < v; ++i)
    {
        cin >> k;
        bitset<10000> otc(0);
        for (int j = 0; j < k; ++j)
        {
            cin >> t;
            otc |= flag[t];
        }
        printf(otc.to_string().substr(10000 - m) == string(m, '1') ? "Yes\n" : "No\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值