AizuOJ ALDS1_7_A Rooted Trees(有根树的表达 左子右兄弟表示法)

A graph G = (VE) is a data structure where V is a finite set of vertices and E is a binary relation on V represented by a set of edges. Fig. 1 illustrates an example of a graph (or graphs).

 
Fig. 1

A free tree is a connnected, acyclic, undirected graph. A rooted tree is a free tree in which one of the vertices is distinguished from the others. A vertex of a rooted tree is called "node."

Your task is to write a program which reports the following information for each node u of a given rooted tree T:

  • node ID of u
  • parent of u
  • depth of u
  • node type (root, internal node or leaf)
  • a list of chidlren of u

If the last edge on the path from the root r of a tree T to a node x is (px), then p is the parent of x, and x is a child of p. The root is the only node in T with no parent.

A node with no children is an external node or leaf. A nonleaf node is an internal node

The number of children of a node x in a rooted tree T is called the degree of x.

The length of the path from the root r to a node x is the depth of x in T.

Here, the given tree consists of n nodes and evey node has a unique ID from 0 to n-1.

Fig. 2 shows an example of rooted trees where ID of each node is indicated by a number in a circle (node). The example corresponds to the first sample input.

 
Fig. 2

Input

The first line of the input includes an integer n, the number of nodes of the tree.

In the next n lines, the information of each node u is given in the following format:

id k cc2 ... ck

where id is the node ID of uk is the degree of uc1 ... ck are node IDs of 1st, ... kth child of u. If the node does not have a child, the k is 0.

Output

Print the information of each node in the following format ordered by IDs:

node id: parent = p , depth = dtype, [c1...ck]

p is ID of its parent. If the node does not have a parent, print -1.

d is depth of the node.

type is a type of nodes represented by a string (root, internal node or leaf). If the root can be considered as a leaf or an internal node, print root.

c1...ck is the list of children as a ordered tree.

Please follow the format presented in a sample output below.

Constraints

  • 1 ≤ n ≤ 100000

Sample Input 1

13
0 3 1 4 10
1 2 2 3
2 0
3 0
4 3 5 6 7
5 0
6 0
7 2 8 9
8 0
9 0
10 2 11 12
11 0
12 0

Sample Output 1

node 0: parent = -1, depth = 0, root, [1, 4, 10]
node 1: parent = 0, depth = 1, internal node, [2, 3]
node 2: parent = 1, depth = 2, leaf, []
node 3: parent = 1, depth = 2, leaf, []
node 4: parent = 0, depth = 1, internal node, [5, 6, 7]
node 5: parent = 4, depth = 2, leaf, []
node 6: parent = 4, depth = 2, leaf, []
node 7: parent = 4, depth = 2, internal node, [8, 9]
node 8: parent = 7, depth = 3, leaf, []
node 9: parent = 7, depth = 3, leaf, []
node 10: parent = 0, depth = 1, internal node, [11, 12]
node 11: parent = 10, depth = 2, leaf, []
node 12: parent = 10, depth = 2, leaf, []

Sample Input 2

4
1 3 3 2 0
0 0
3 0
2 0

Sample Output 2

node 0: parent = 1, depth = 1, leaf, []
node 1: parent = -1, depth = 0, root, [3, 2, 0]
node 2: parent = 1, depth = 1, leaf, []
node 3: parent = 1, depth = 1, leaf, []

Note

You can use a left-child, right-sibling representation to implement a tree which has the following data:

  • the parent of u
  • the leftmost child of u
  • the immediate right sibling of u

Reference

Introduction to Algorithms, Thomas H. Cormen, Charles E. Leiserson, Ronald L. Rivest, and Clifford Stein. The MIT Press.

 

题意:

  输出给定有根树的T中的各结点u的信息,信息内容如下。

  1. u的结点编号
  2. u的结点种类(根、内部结点、叶)
  3. u的父结点编号
  4. u的子结点列表
  5. u的深度

输入:第一行是结点的个数n。接下来的n行按照下述格式输入各结点的信息,每个结点占一行。

   id k c1c2...ck

  id为结点编号 k为度。c1c2...ck为第一个子结点到第k个子结点的编号。

输出:请看输出示例。

 

 

分析:这题要求父节点是谁  所以用孩子兄弟法表示比较好  左边递归就是层数  右边是兄弟  

#include<bits/stdc++.h>
using namespace std;
const int N=1e5+100;
const int nl=-1;
struct node
{
	int p,l,r;
}T[N];
int leve[N];
void rec(int u,int p)
{
	leve[u]=p;
	if(T[u].r!=nl) rec(T[u].r,p);//右侧兄弟设置为相同深度
	if(T[u].l!=nl) rec(T[u].l,p+1);//最左侧结点的深度设置为自己深度+1 
 } 
void print(int u)
{
	
	cout<<"node "<<u<<": ";
	cout<<"parent = "<<T[u].p<<", ";
	cout<<"depth = "<<leve[u]<<", ";
	if(T[u].p==nl) cout<<"root, ";
	else if(T[u].l==nl) cout<<"leaf, ";
	else  cout<<"internal node, ";
	cout<<"[";
	bool flag=false;
	for(int i=T[u].l;i!=nl;i=T[i].r){//一直往右边的结点找都是兄弟 
		if(flag) cout<<", ";
		cout<<i;
		flag=true;
	}
	cout<<"]"<<endl;
 	
} 
int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++) T[i].p=nl,T[i].l=nl,T[i].r=nl;
	for(int i=0;i<n;i++){
		int v,d;
		cin>>v>>d;
		int t;
		for(int j=0;j<d;j++){
			int c;
			cin>>c;
			if(j==0){
				T[v].l=c;//表示的是孩子 
			}
			else{
				T[t].r=c;// 表示的是兄弟 
			}
			t=c;
			T[c].p=v;
		}
	}
	int id;
	for(int i=0;i<n;i++){
		if(T[i].p==nl){
			id=i;
			break;
		}
	}
	rec(id,0);
	for(int i=0;i<n;i++){
		print(i);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值