hdu 5873 Football Games

Football Games

A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced. 
   
  At the first phase of the championships, teams are divided into  M M groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available. 
   
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
Input
Multiple test cases, process till end of the input. 
   
  For each case, the first line contains a positive integers  M M, which is the number of groups. 
  The  i i-th of the next  M M lines begins with a positive integer  Bi Bi representing the number of teams in the  i i-th group, followed by  Bi Bi nonnegative integers representing the score of each team in this group. 


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
Output
For each test case, output  M M lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
Sample Input
2
3 0 5 1
2 1 1
Sample Output
F
T
 
 
输入方法第一次见有酱紫的,交了好多发没有看出来,错了好多!
每一次比赛双方取得的总分肯定是2,所以,所有比赛的总分一定是M*(M-1),所以求和判断一下即可,
还有就是每个队伍会和其他(M-1)支队伍比赛,所以取得的最高分数就是2*(M-1),然后再加个判断即可;
代码如下:
#include <stdio.h>
#include <algorithm>
bool solve() {
	int a[100050] , k = 0 , sum = 0, M , s1 = 0 , s2 = 0;
	scanf("%d",&M);
	for(int i = 0; i < M; i++) {
		scanf("%d",&a[i]);
		sum += a[i];
		if(a[i] > 2*(M - 1)) {
			k = 1;
		}
	}
	if(sum != M*(M-1) || k)
	return 0;
	return 1;
}
int main() {
	int m;
	while(~scanf("%d",&m)) {
		while(m--) {
			if(solve())
			printf("T\n");
			else printf("F\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值