HDU 5980

 Find Small A
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1170 Accepted Submission(s): 578


Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).


Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai≤2^32 - 1) follow


Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.


Sample Input

3
97 24929 100



Sample Output

3

题意:就是输入N个整数,那么这N个整数不都是以32位存的吗?现在让你把输入的每一个数如果写成32位,把它分为4份,每次取其中的8位为一个数,为这个数是不是97;要求你记录这N个数进过这样的操作后其中有几个97?

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#define N 100000
using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
	long long cnt=0;
	long long p = 2*2*2*2*2*2*2*2- 1;
	for(int i=0;i<n;i++)
        {
		long long d;
		scanf("%lld",&d);
		long long temp=d;
		int j=0;
		while(j<=4)
               {
		    int k=8*j;
			j++;
			temp=d >> k;
			temp=temp&p;
			if(temp==97)
				cnt++;
		}
	}
	printf("%lld\n",cnt);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值