Description
Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?
Input
The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.
Output
For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.
Sample Input
1 2 3 1 2 3 2 2 3
Sample Output
3 3 4
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
int a[2010][2010];
int b[2010];
int main()
{
priority_queue<int >Q;
int T;
scanf("%d",&T);
while(T--)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=0; i<n; i++)
{
for(int j=0; j<m; j++)
scanf("%d",&a[i][j]);
sort(a[i],a[i]+m);
}
for(int i=0; i<m; i++)
Q.push(a[0][i]);
for(int i=1; i<n; i++)
{
for(int j=0; j<m; j++)
{
b[j] = Q.top();
Q.pop();
}
for(int j=0; j<m; j++)
{
for(int k=m-1; k>=0; k--)
{
if(j)
{
if(a[i][j]+b[k] > Q.top())
break;
Q.push(a[i][j]+b[k]);
Q.pop();
}
else
Q.push(a[i][j] + b[k]);
}
}
}
for(int i=0;i<m;i++)
{
b[i] = Q.top();
Q.pop();
}
for(int i=m-1;i>=0;i--)
{
if(i == 0)
printf("%d\n",b[i]);
else
printf("%d ",b[i]);
}
}
return 0;
}