Can you find it? 二分

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO
 
 
前将前两组相加构成新数组,对新生成的进行二分
#include<iostream>
#include<algorithm>
using namespace std;
int a[505],b[505],c[505],d[250005],l,n,m,x,s,tp,ed,mid,num=0;
bool cmp(int A,int B)
{
    return A<B;
}
int fun(int x)
{
    for(int i=0;i<m;i++)
    {
        tp=0;
        ed=l*n-1;
        while(tp<=ed)
        {
            mid=(tp+ed)>>1;
            if ((d[mid]+c[i])==x) return 1;
            if ((d[mid]+c[i])<x) tp=mid+1;
            else ed=mid-1;
        }
    }
    return 0;
}
int main()
{
    while(cin>>l>>n>>m)
    {
        num++;
        cout<<"Case "<<num<<":"<<endl;
        for(int i=0;i<l;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
            cin>>b[i];
        for(int i=0;i<m;i++)
            cin>>c[i];
        for(int i=0;i<l;i++)
            for(int j=0;j<n;j++)
                d[i*n+j]=a[i]+b[j];
        sort(d,d+l*n,cmp);
        cin>>s;
        while(s--)
        {
            cin>>x;
            if (fun(x)) cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值