Fibonacci (POJ - 3070 )(矩阵快速幂)

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.这里写图片描述

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

详情见http://blog.csdn.net/coldfresh/article/details/70948818
代码几乎一模一样,没有本质的改动,只是系数矩阵m不同
.
代码:

import java.util.Scanner;

public class Main 
{
    public static void main(String[]args)
    {
        Scanner sc=new Scanner(System.in);
        M m=new M();
        m.a[0][0]=1;
        m.a[0][1]=1;

        m.a[1][0]=1;
        m.a[1][1]=0;

        M o=new M();
        o.a[0][0]=1;
        o.a[1][1]=1;
        for(;;)
        {
            int n=sc.nextInt();
            if(n==-1)
                break;
            M k=o.copy();
            M l=m.copy();
            while(n>0)
            {
                if((n&1)==1)
                {
                    k=k.muip(l);
                }
                l=l.muip(l);
                n>>=1;
            }
            System.out.println(k.a[1][0]);
        }
    }

}
class M
{
    long a[][]=new long[2][2];
    M muip(M x)
    {
        M m=new M();
        for(int i=0;i<2;i++)
            for(int j=0;j<2;j++)
            {
                m.a[i][j]=(a[i][0]*(x.a[0][j]%10000)+a[i][1]*(x.a[1][j]%10000))%10000;
            }
        return m;
    }
    M copy()
    {
        M m=new M();
        for(int i=0;i<2;i++)
            for(int j=0;j<2;j++)
            {
                m.a[i][j]=a[i][j];
            }
        return m;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值