杭电 1002[A + B Problem II]

终于解决了这两天纠结死我了。


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

作为一个菜鸟,原谅我沾沾自喜并且贴上源代码自我满足一番。

#include <iostream>
using namespace std;
#define max 1000
void main()
{
	char a[max],b[max];
	int sum[max+1];
	int n,lenA,lenB,jw=0,maxlen,t,i,c;
	cin>>n;
	for(c=1;c<=n;c++)
	{
		cin>>a>>b;
		lenA=strlen(a);
		lenB=strlen(b);
		lenA>lenB?maxlen=lenA:maxlen=lenB; 
		t=maxlen;
		for( ; lenA>0 && lenB>0 ; lenA-- , lenB--,t--)
		{
			sum[t]=(a[lenA-1]-'0')+(b[lenB-1]-'0'+jw);
			jw=0;
			if(sum[t]>=10) 
			{
				sum[t]-=10;
				jw=1;
			}
		}
		while(t)
		{
			if(lenA)   {sum[t]=(a[t-1]-'0')+jw; jw=0;}
			else        {sum[t]=(b[t-1]-'0')+jw;jw=0;}
			t--;
		}
		cout<<"Case "<<c<<":"<<endl;
		cout<<a<<" + "<<b<<" = ";
		sum[0]=jw;
		if(sum[0]==0) i=1;
		else i=0;
		for( ;i<=maxlen;i++)  cout<<sum[i];
		if(c==n) cout<<endl;
		else cout<<endl<<endl;
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值