HDU 1395 2^x mod n = 1

2^x mod n = 1

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 

Input
One positive integer on each line, the value of n.
 

Output
If the minimum x exists, print a line with 2^x mod n = 1.
Print 2^? mod n = 1 otherwise.
You should replace x and n with specific numbers.
 
Sample Input
  
  
2 5
 
Sample Output
  
  
2^? mod 2 = 1 2^4 mod 5 = 1

题意:输入一个数,计算2的几次方能除以它取余等于1。输出格式如上。

这道题终点在数值上,也许x有很大,久指数爆炸了,所以不能直接求2的多少次方,要乘一次取一次余。

#include<stdio.h>
int main()
{
    int k,e,n;
    while(~scanf("%d",&n))
    {
        printf("2^");
        if(n%2==0||n==1)
        {
            printf("?");
            goto end;
        }
        e=0;
        k=1;
        while(++e)
        {
            k<<=1;
            k%=n;
            if(k==1)
            {
                printf("%d",e);
                goto end;
            }
        }
end:
        printf(" mod %d = 1\n",n);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值