1080 Graduate Admission (30分)

13 篇文章 0 订阅

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.
Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G​E​​ and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

题⽬⼤意:

每个考⽣有两个成绩:GE和GI,最终成绩为(GE + GI) / 2;按照最终成绩排名,如果最终成绩
相同,就按照GE排名,如果仍然相同,他们的排名就是相同的。每个申请者有K个选择院校,每个学
校也有招⽣⼈数限制。按照排名先后,如果当前考⽣的第⼀个志愿学校的名额还没满,就录取进去;
如果当前志愿名额满了但是该校最后⼀个录取的⼈的排名和当前考⽣相同,则不管招⽣⼈数限制,依
旧应该被录取;否则考虑该⽣的下⼀个志愿。如果所有志愿都没有能被录取,则该⽣落榜。

分析:

1.stu容器⾥放学⽣{id, ge, gi, total, choice(放学⽣报考学校的id),admit存放该生录取院校}, quota数组放招⽣计划的数量,
admision容器⾥存放的是学校已经招的学⽣的id
2.对学⽣按照分数排序,依次学⽣遍历,分数最⾼的学⽣先挑学校
3.对于每个学⽣录取到哪⾥:依次遍历学⽣的报考志愿,如果(没招满 || 他与已经招的学⽣的最后⼀
名成绩并列)就把他招进去,该学⽣录取结果即可确定,并把次学⽣加⼊该学校录取容器中
4.输出学校录取情况时学⽣id顺序是乱的,要先从⼩到⼤排序,然后输出。每个学校占⼀⾏。
5.排序函数要⽤ & 引⽤传参,不然会超时
6.因为分数 total = ge + gi 不会超出int, total/ 2 和total排名效果⼀样, 不除2不会影响结果,⽽且还可以巧妙
躲避除2后double不能精确表示的问题

属于PAT排序里比较综合的题目值得学习

//1080 Graduate Admission (30分)
#include <bits/stdc++.h>
using namespace std;
struct stu
{
	int id,ge,gi;
	double total;
	int choice[5];
	int rank;
	int admit;
};
int quota[100];
set<int> admission[100];
bool cmp(stu s1,stu s2)
{
	if((int)s1.total!=(int)s2.total)
		return (int)s1.total>(int)s2.total;
	else if(s1.ge>s2.ge)
		return s1.ge>s2.ge;
	else if(s1.id!=s2.id)
		return s1.id<s2.id;
}
int main()
{
	int n,m,k;
	cin>>n>>m>>k;
	vector<stu> s(n);
	for(int i=0; i<m; i++)
	{
		cin>>quota[i];
	}
	for(int i=0; i<n; i++)
	{
		cin>>s[i].ge>>s[i].gi;
		s[i].id=i;
		s[i].total=(s[i].ge+s[i].gi)*1.0/2;
		for(int j=0; j<k; j++)
			cin>>s[i].choice[j];
	}
	sort(s.begin(),s.end(),cmp);

	s[0].rank=1;
	for(int i=1; i<n; i++)
	{
		s[i].rank=i+1;
		if((int)s[i].total==(int)s[i-1].total&&s[i].ge==s[i-1].ge)
		{
			s[i].rank=s[i-1].rank;
		}
	}
	admission[s[0].choice[0]].insert(s[0].id);
	s[0].admit=s[0].choice[0];
	for(int i=1; i<n; i++)
	{

		for(int j=0; j<k; j++)
		{

			if(admission[s[i].choice[j]].size()<quota[s[i].choice[j]])
			{
				admission[s[i].choice[j]].insert(s[i].id);
				s[i].admit=s[i].choice[j];
				break;
			}
			else
			{
				if(s[i].rank==s[i-1].rank&&s[i].choice[j]==s[i-1].admit)
				{
					admission[s[i].choice[j]].insert(s[i].id);
					s[i].admit=s[i].choice[j];
					break;
				}
			}
		}

	}
	for(int i=0; i<m; i++)
	{
		for(auto it=admission[i].begin(); it!=admission[i].end(); it++)
		{
			if(it==admission[i].begin())
				cout<<*it;
			else
				cout<<" "<<*it;
		}
		cout<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值