1061 Dating (20分)

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

题⽬⼤意:

福尔摩斯接到⼀张奇怪的字条:“我们约会吧!3485djDkxh4hhGE 2984akDfkkkkggEdsbs&hgsfdk d&Hyscvnm”。⼤侦探很快就明⽩了,前⾯两字符串中第1对相同的⼤写英⽂字⺟(⼤⼩写有区分)是第4个字⺟D,代表星期四;第2对相同的字符是E,那是第5个英⽂字⺟,代表⼀天⾥的第14个钟头(于是⼀天的0点到23点由数字0到9、以及⼤写字⺟A到N表示);后⾯两字符串第1对相同的英⽂字⺟s出现在第4个位置(从0开始计数)上,代表第4分钟。现给定两对字符串,要求解码得到约会的时间

分析:

按照题⽬所给的⽅法找到相等的字符后判断即可,如果输出的时间不⾜2位数要在前⾯添0,即⽤%02d输出

注意

注意注释部分break的使用,若写在外面当 *==*时就跳出循环,导致后面没有小时数,即多个判断条件拆开写时,一定要注意break的位置

//1061 Dating (20分)
#include <bits/stdc++.h>
using namespace std;
string week[]= {"MON","TUE","WED","THU","FRI","SAT","SUN"};
int main()
{
	string str1,str2,str3,str4;
	cin>>str1>>str2>>str3>>str4;
	int i;
	for(i=0; i<str1.length()&&i<str2.length(); i++)
	{
		if(str1[i]>='A'&&str1[i]<='G'&&str1[i]==str2[i])
		{
			cout<<week[str1[i]-'A'];
			break;
		}
	}
	for(i=i+1; i<str1.length()&&i<str2.length(); i++)
	{
		if(str1[i]==str2[i])//&&((str1[i]>='A'&&str1[i]<='N')||isdigit(str1[i]))
		{
			//int m=isdigit(str1[i])?str1[i]-'0':str1[i]-'A'+10;
			//printf(" %02d",m);
			if(str1[i]>='A'&&str1[i]<='N')
			{
				printf(" %d",str1[i]-'A'+10);
				break;
			}

			else if(isdigit(str1[i]))
			{
				printf(" %02d",str1[i]-'0');
				break;
			}

		//	break;
		}
	}
	for(int i=0; i<str3.length()&&i<str4.length(); i++)
	{
		if(str3[i]==str4[i]&&isalpha(str3[i]))
		{
			printf(":%02d",i);
			return 0;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值