PAT 1001 A+B Format

题目

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9
Sample Output:

代码

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;// 要写这个才能用cin
int main(){
    int a,b,sum,len;
    cin>>a>>b;
    sum=a+b;
    string s=to_string(sum);
    if(s[0]=='-')
    {
        cout<<s[0];
        s.erase(0,1);//s.erase(0,1)
        
    }
    reverse(s.begin(),s.end()); //reverse  而非s.reverse
    len=(int)s.size();
    for(int i=3;i<len;i+=3) //!!从i=3 开始而非0
    {
        //想要插入,然后统一输出
        s.insert(i,",");//s[i].append??????
        i++;// ,算一个位置
        len++; //长度+

    }
    reverse(s.begin(),s.end());
    cout<<s;
    return 0;
}

领悟

  1. 题目中Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits 一开始没注意到three,然后没能理解题意,读题要细致
  2. stiring s=to_string(sum);to_string函数
  3. s.erase(0,1)从下标0开始,长度为1
  4. reverse(s.begin(),s.end())不是s.reverse 注意拼写
  5. s.insert(从下标n,插入的内容)
  6. for(int i=3;i<len;i+=3) //!!从i=3 开始而非0
  7. i++;// ,算一个位置-为了for循环的运行
    len++; //整体长度+
nike genre c语言版本
#include<stdio.h>

int main(){
    int a,b,sum=0,n=0,flag=0,i;
    char s[8];
    scanf("%d %d",&a,&b);
    sum=a+b;
    if(sum==0) {printf("0");return 0;}
    if(sum>0) {n=sum;flag=1;}
    else n=-sum;
    for(i=0;i<8&&n!=0;i++){
        s[i]=n%10+'0';
        n/=10;
    }
    if(flag){
        for(i=i-1;i>=0;i--){
            printf("%c",s[i]);
            if(i==6||i==3) printf(",");
        }
    }else{
        printf("-");
        for(i=i-1;i>=0;i--){
            printf("%c",s[i]);
            if(i==6||i==3) printf(",");
        }
    }
    return 0;
}

嘿嘿嘿!c++真好用,函数要多多积累!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值