Matrix Transpose


  A: Matrix Transpose 

A matrix is a rectangular array of elements, most commonly numbers. A matrix with $m$ rows and $n$ columns is said to be an $m$-by- $n$ matrix. For example,

\begin{displaymath}A=\pmatrix{1 & 3 & 2 \cr 0 & 4 & -1 \cr 0 & 0 & 0 \cr 5 & -2 & 11}\end{displaymath}

is a 4-by-3 matrix of integers.

The individual elements of a matrix are usually given lowercase symbols and are distinguished by subscripts. The $i$th row and $j$th column of matrix $A$ is usually referred to as $a_{ij}$. For example, $a_{23}=-1$. Matrix subscripts are 1-based.

The transpose of a matrix $M$, denoted $M^T$, is formed by interchanging the rows and columns of $M$. That is, the $ij$th element of $M^T$ is the $ji$th element of $M$. For example, the transpose of matrix $A$ above is:

\begin{displaymath}A^T=\pmatrix{1 & 0 & 0 & 5 \cr 3 & 4 & 0 & -2 \cr 2 & -1 & 0 & 11}\end{displaymath}

A matrix is said to be sparse if there are relatively few non-zero elements. As a $m$-by-$n$ matrix has $mn$ number of elements, storing all elements of a large sparse matrix may be inefficient as there would be many zeroes. There are a number of ways to represent sparse matrices, but essentially they are all the same: store only the non-zero elements of the matrix along with their row and column.

You are to write a program to output the transpose of a sparse matrix of integers.

Input 

You are given several sparse matrix in a row, each of them described as follows. The first line of the input corresponds to the dimension of the matrix, $m$ and $n$ (which are the number of rows and columns, respectively, of the matrix). You are then given $m$ sets of numbers, which represent the rows of the matrix. Each set consists of two lines which represents a row of the matrix. The first line of a set starts with the number $r$, which is the number of non-zero elements in that row, followed by $r$ numbers which correspond to the column indices of the non-zero elements in that row, in ascending order; the second line has $r$ integers which are the matrix elements of that row. For example, matrix $A$ above would have the following representation:

4 3
3 1 2 3
1 3 2
2 2 3
4 -1
0

3 1 2 3
5 -2 11
Note that for a row with all zero elements, the corresponding set would just be one number, ` 0', in the first line, followed by a blank line.

You may assume:

  • the dimension of the sparse matrix would not exceed 10000-by-10000,

  • the number of non-zero element would be no more than 1000,

  • each element of the matrix would be in the range of -10000 to 10000, and

  • each line has no more than 79 characters.

Output 

For each input case, the transpose of the given matrix in the same representation.

Sample Input 

4 3
3 1 2 3
1 3 2
2 2 3
4 -1
0

3 1 2 3
5 -2 11

Sample Output 

3 4
2 1 4
1 5
3 1 2 4
3 4 -2
3 1 2 4
2 -1 11


题意主要是输入一个矩阵,是零不输出,并记下不是零的位置,然后输出它的转置矩阵。
#include<stdio.h>
#include<string.h>
int ans[1007];
int z[1007][1007],y[1007][1007],mat[1007][1007],tmat[1007][1007];
int main()
{
    int m,n,i,j,a,b;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(mat,0,sizeof(mat));
        for(i=0; i<m; i++)
        {
            int count;
            scanf("%d",&count);
            for(a=0; a<count; a++)
                scanf("%d",&z[i][a]);
            for(b=0; b<count; b++)
                scanf("%d",&y[i][b]);
            for(j=0; j<count; j++)
            {
                int t=z[i][j]-1;
                mat[i][t]=y[i][j];
            }
        }

        //记下转置矩阵
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                tmat[i][j]=mat[j][i];
            }
        }
        printf("%d %d\n",n,m);

        memset(ans,0,sizeof(ans));
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if(tmat[i][j]!=0)
                    ans[i]++;//记下有几个非0的个数
            }
        }
        int flag;
        for(i=0; i<n; i++)
        {
            printf("%d",ans[i]);
            if(ans[i]==0)
            {
                printf("\n\n");
                continue;
            }
            for(j=0; j<m; j++)
            {
                if(tmat[i][j]!=0)
                {
                    printf(" %d",j+1);
                }
            }
            printf("\n");
            for(int e=0; e<m; e++)
            {
                if(tmat[i][e]!=0)
                {
                    printf("%d",tmat[i][e]);
                    flag=e;
                    break;//防止格式错误
                }

            }
            for(int f=flag+1; f<m; f++)
            {
                if(tmat[i][f]!=0)
                    printf(" %d",tmat[i][f]);
            }

            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值