杭电1062 之 Text Reverse

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca

Sample Output
  
  
hello world! I'm from hdu. I like acm.
题意:交换单词位置,每个单词之间有若干个空格隔开
例如:“ asdas ghty,. yui ” 的对应输出为“ sadsa .,ythg iuy
AC代码如下:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int maxn=1000+10;
char a[maxn];

void fun(int row,int col)
{
    for(int i=row;i<=(row+col)/2;i++)
    {
        char temp=a[i];
        a[i]=a[row+col-i];
        a[row+col-i]=temp;
    }
}

int main()
{
    int t;
    cin>>t;
    getchar();
    while(t--)
    {
        gets(a);
        int row=0,col=0;
        int len=strlen(a);
        for(int i=0;i<len;i++)
        {
            if(a[i]==' ')
            {
                cout<<" ";
                continue;
            }
            if(a[i]!=' ')
            {
                row=i;
                while(i<len && a[i]!=' ')
                {
                    i++;
                }
                i--;
                col=i;
                fun(row,col);
                for(int j=row;j<=col;j++) cout<<a[j];
            }
        }
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值