【PAT】1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
分析:用两个结构数组存储;用一个优先队列计算所有相乘后的数;用另一个优先队列把相乘后的数进行指数合并

细节:存在系数为0的可能。


#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <queue>
#include <vector>
#include <functional>

#define rep(i,j,k) for(int i=j;i<=k;++i)
const int Max=10;

using namespace std;

struct node
{
	int e;
	float c;
	friend bool operator < (const node& m, const node& n){
		return m.e<n.e;
	}
};
node a[Max], b[Max];

priority_queue<node> q,q1;

int main()
{
//	freopen("test.txt","r",stdin);
	int x,y;
	cin>>x;
	rep(i,0,x-1){
		cin>>a[i].e>>a[i].c;
	}
	cin>>y;
	rep(i,0,y-1){
		cin>>b[i].e>>b[i].c;
		rep(j,0,x-1){
			node t;
			t.e=b[i].e+a[j].e;
 			t.c=b[i].c*a[j].c;
			q.push(t);
		}
	}
	int te=0;
	float tc=0;
	while(!q.empty()){
		te=q.top().e;
		tc+=q.top().c;
		q.pop();
		if (!q.empty() && te==q.top().e) continue;
		else {
			node t;
			t.e=te;
			t.c=tc;
			if (t.c==0) continue;//
			q1.push(t);
			tc=0;	
		}
	}
	cout<<q1.size();
	while(!q1.empty()){
		printf(" %d %.1f", q1.top().e, q1.top().c);
		q1.pop();
	}
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值