PAT A1032 Sharing (25)(25 分)

题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5^), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

算法思路:

先统计输入的两个字符的长度;把字符长度较长的指针后移直到两个字符串的长度相等。(因为,如果两个字符有公共的存储点时,存储点之后的字符长度肯定是相同的。)然后两个字符串在开始分别设置一个指针,每次后移一个位置,直到相等,因为如果没有的话会返回-1,所以肯定有相等的情况。

之后判断返回的位置是否为-1,如果为-1,则没有相同的结点。

代码展示:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxLen = 100010;
struct node {
	char c;
	int next;
}nodes[maxLen];

int countLen(int add){
	int len = 0;
	while(add != -1){
		len++;
		add = nodes[add].next;
	}
	return len;
}

int main(){
	int first1,first2,N;
	scanf("%d%d%d",&first1,&first2,&N);
	int add;
	for(int i=0;i<N;i++){
		scanf("%d  ",&add);
		scanf("%c %d",&nodes[add].c,&nodes[add].next);
		//printf("add=%d \t c = %c \t next = %d \t %d \n",add,nodes[add].c,nodes[add].next,i);
	}
	int len1 = countLen(first1);
	int len2 = countLen(first2);
	int longer,shorter;
	if(len1>len2){
		longer = first1;
		shorter = first2;
	}else{
		shorter = first1;
		longer = first2;
		swap(len1,len2);
	}
	while(abs(len1-len2)){
		longer = nodes[longer].next;
		len1--;
	}
	for(int i = 0;i < len2 ; i++){
		if(longer == shorter)
			break;
		shorter = nodes[shorter].next;
		longer = nodes[longer].next;
	}
	if(longer != -1){
  	printf("%05d\n",longer);
	}else{
	  printf("-1\n");
	}
	return 0;
}

 注意:

一定要注意题目要求的输出格式。

输入含义
%-5d左对齐5位整数
%5d

右对齐5位整数,不够补空格

%05d

右对齐5位,不够补0

%15.2f共15位,带两位小数的浮点数,不够补空格

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值