A - ArcSoft's Office Rearrangement(万恶的long long)

ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:

  • merge two neighbor blocks into a new block, and the new block’s size is the sum of two old blocks’.
  • split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K
block with equal size, please help him.
Input
First line contains an integer T, which indicates the number of test cases.

Every test case begins with one line which two integers N and K, which is the number of old blocks and new blocks.

The second line contains N numbers a1, a2, ⋯, aN, indicating the size of current blocks.

Limits
1≤T≤100
1≤N≤105
1≤K≤105
1≤ai≤105
Output
For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can't re-arrange K
new blocks with equal size, y equals -1.

Sample Input

3
1 3
14
3 1
2 3 4
3 6
1 2 3

Sample Output

Case #1: -1
Case #2: 2
Case #3: 3

做完这次比赛,深深地感觉到了什么是绝望,差点没签到。。。。
看到莹巨发了一个说说,说由于她读错题目,害的两个队员做了一晚上签到题。。。
其实,我更应该发个说说,由于我的long long int ,害的三个队员差点没A出一道题目,真的心塞,下面的代码,就是我第一次提交的,WA,赛后我一直觉得自己的代码没问题,后来才发现,全都是long long int惹的祸,下面的代码我只是把所有的int都改成了long long int ,再次提交居然A了。。。。。。。。
就只是水题一道,按照要求,从左到右,大的就拆,小的就合并。。。

#include <iostream>
#include <cstdio>
using namespace std;
long long int ma[121231];
int main()
{
    long long int n, k, t;
    scanf("%lld", &t);
    for(long long int Case = 1; Case<=t; Case++)
    {
        scanf("%lld %lld", &n, &k);
        long long int ans = 0;
        for(long long int i=0; i<n; i++)
        {
            scanf("%lld", &ma[i]);
            ans = ans + ma[i];
        }
        long long int step =  0;
        if(ans%k!=0)
        {
            printf("Case #%lld: -1\n", Case, -1);
        }
        else
        {
            long long int ka = ans / k;
            long long int num = 0;
            for(long long int i =0; i<n; i++)
            {
                if(num!=0)
                    step++;
                num = num + ma[i];
                if(num >= ka)
                {
                    while(num >= ka)
                    {
                        num-=ka;
                        step++;
                    }
                    if(num==0)
                      step--;
                }
            }
            printf("Case #%lld: %lld\n", Case, step);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值