POJ 1456 Supermarket (贪心+并查集)

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

这里写图片描述
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10
Sample Output

80
185
Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
题意:这个题就是给出了买物品的价值和最终截止时间,该物品只有在截止时间之前卖出去才能获得该价值,每卖出一个物品就要消耗1单位时间。主要算法是贪心,将所有物品的价值排序,当截止时间相同的时候优先选择价值高的物品。而并查集的作用就是将时间链接起来,找到不冲突的时间点,只有在这个时间点上的物品才能卖出去。 这里并查集的作用类似于链表指针,压缩的过程就是删掉节点的过程。从而在O(1)的时间内找到那个不冲突的点。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 10010
int f[maxn];
struct node
{
    int w,end;
}q[maxn];
int cmp(node a,node b)
{
    return a.w>b.w;
}
int find(int x)
{
    return f[x]==x?x:(f[x]=find(f[x]));
}
int main()
{
    int n,r,i;
    while(~scanf("%d",&n))
    {
        int sum=0;
        for(i=0;i<maxn;i++)
            f[i]=i;
        for(i=0;i<n;i++)
            scanf("%d%d",&q[i].w,&q[i].end);
        sort(q,q+n,cmp);
        for(i=0;i<n;i++)
        {
            r=find(q[i].end);
            if(r>0)
            {
                f[r]=r-1;
                sum+=q[i].w;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值