HDU - 1622 Trees on the level

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree


is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题解:输入一棵二叉树,相邻结点之间用一个空格隔开。每棵树的输入用一对空括号“()”结束。从上到下、从左到右的输出各个结点的值。

这篇博客写的很详细https://blog.csdn.net/q547550831/article/details/51366645

#include<cstdio>
#include<cstring>
#include<string>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
    int x,y;
    string s;
} e[1100];
bool cmp(node a,node b)
{
    if(a.y==b.y)
        return a.s<b.s;
    return a.y<b.y;
}
int main()
{
    string mp;
    map<string,int>v;
    int n=0,flag=0;
    while(cin>>mp)
    {
        int i,j,ans[550];
        if(mp=="()")
        {
            sort(e,e+n,cmp);
            if(flag||e[0].y!=0)
                printf("not complete\n");
            else
            {
                for(i=0; i<n; i++)
                {
                    if(e[i].y>0)
                    {
                        string s;
                        int l=e[i].s.size();
                        for(j=0; j<l-1; j++)
                            s+=e[i].s[j];
                        if(v[s]!=1)
                        {
                            flag=1;
                            break;
                        }
                    }
                    ans[i]=e[i].x;
                }
                if(flag)
                    printf("not complete\n");
                else
                {
                    for(i=0; i<n; i++)
                    {
                        if(i<n-1)
                            printf("%d ",ans[i]);
                        else
                            printf("%d\n",ans[i]);
                    }
                }
            }
            n=0,flag=0;
            v.clear();
            continue;
        }
        int p=0,l=mp.size();
        for(i=1; i<l; i++)
        {
            if(mp[i]==',')
                break;
            p=p*10+mp[i]-'0';
        }
        e[n].x=p;
        p=0;
        e[n].s.clear();
        for(i=i+1; i<l; i++)
        {
            if(mp[i]==')')
                break;
            p++;
            e[n].s+=mp[i];
        }
        v[e[n].s]++;
        if(v[e[n].s]>=2)
            flag=1;
        e[n++].y=p;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值