POJ-3295 Tautology (构造法)

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13860 Accepted: 5350

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

代码:

#include <algorithm>
#include <iostream>
#include <stdio.h>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include<cmath>
#include <stack>
#include<cstdlib>
#include<ctime>
using namespace std;
map<char,int> m;
int len;
char str[105];
int valid(){
	stack<int> s;
	char ch;
	int t1,t2;
	for(int i =len - 1;i>=0;i--){
		if(str[i] == 'K' || str[i] == 'A' || str[i] == 'C' || str[i] == 'E'){
			//二元运算符
			t1 = s.top();s.pop();
			t2 = s.top();s.pop();
			if(str[i] == 'K') s.push(t1&&t2);
			else if(str[i] == 'A') s.push(t1||t2);
			else if(str[i] == 'C'){
				if(t1 == 0&&t2 == 1) s.push(0);
				else s.push(1);
			}
			else if(str[i] == 'E') s.push(t1 == t2);
		}
		else if(str[i] == 'N'){//一元运算符 
			t1 = s.top(); s.pop();
			s.push(!t1);
		}
		else s.push(m[str[i]]);
	}
	return s.top();
}
int main() {
	while(scanf("%s",str),str[0]!='0'){
		len = strlen(str);
		int flag = 1;
		for(int p = 0;p<2&&flag;p++){
			m['p'] = p;
			for(int q = 0;q<2&&flag;q++){
				m['q'] = q;
				for(int r = 0;r<2&&flag;r++){
					m['r'] = r;
					for(int s = 0;s<2&&flag;s++){
						m['s'] = s;
						for(int t = 0;t<2&&flag;t++){
							m['t'] = t;
							if(!valid()) flag = 0;
						}
					}
				}
			}
		}
		if(flag) printf("tautology\n");  
        else printf("not\n");  
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值