This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
KN1a N1N2 aN 2 … NK aN K
where K is the number of nonzero terms in the polynomial, Ni and aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK <⋯<N2 <N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行
Sample Output:
3 3 3.6 2 6.0 1 1.6
结尾无空行
感觉还是最大数组法做比较方便,注意结果最大系数是最大系数之和1001
#include<iostream>
#include<vector>
using namespace std;
float A[2001][3]={0};
int main(){
for(int i=0;i<2;i++){
int M;
cin>>M;
for(int j=0;j<M;j++){
int exp;
cin>>exp;
cin>>A[exp][i];
}
}
for(int i=0;i<1001;i++){
for(int j=0;j<1001;j++){
A[i+j][2]+=A[i][0]*A[j][1];
}
}
int n=0;
for(int i=2001;i>=0;i--){
if(A[i][2]!=0.0) n++;
}
printf("%d",n);
for(int i=2001;i>=0;i--){
if(A[i][2]!=0.0) printf(" %d %.1f",i,A[i][2]);
}
}