O - Number Sequence

Number Sequence

题目描述

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Iutput

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2


思路:

模拟分组,把 1 看做第 1 组,12 看做第 2 组,123 看做第 3 组……那么第 i 组就是存放数字序列为 [ 1,i ] 的正整数,但第 i 组的长度不一定是 i
已知输入查找第 n 个位的 n 的范围为 (1 ≤ n ≤ 2147483647 ),那么至少要有 31268 个组才能使得数字序列达到有第 2147483647 位
注意:2147483647 刚好是 int 的正整数最大极限值( ),所以对于 n 用 int 定义就足矣。但是 pos [ 31268 ] 存在超过 2147483647 的位数,因此要用 unsigned 或 long long 之类的去定义 pos [ ]

其中:( int ) log10 ( i * 1.0 ) + 1 是求某个数所占的空间


代码

#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
#include<cmath>
#include<queue>
#define LL long long
using namespace std;
LL s[100000],a[100000];
LL so(LL x,LL d)
{
    while(d--)
    {
        x/=10;
    }
    return x%10;
}
int main()
{
    LL n,m,i,cla;
    a[1]=s[1]=1;
    for(i=2;i<=34000;i++)//先打表
    {
        a[i]=a[i-1]+(LL)log10((double)i)+1;
        s[i]=s[i-1]+a[i];
    }
    scanf("%I64d",&cla);
    while(cla--)
    {
        scanf("%I64d",&n);
        i=0;
        while(s[i]<n)
            i++;
        m=n-s[i-1];//找到在n在全部序列里的下标
        i=0;
        while(m>a[i])
        i++;//i为所在n组的长度
        printf("%I64d\n",so(i,a[i]-m) );
        //例如要取出1234的2,那么多余的位数有2位:34。
        //那么用1234 / 100,得到12,再对12取模10,就得到2
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值