PTA甲级 1032 Sharing (25分)


强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解
算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

生词如下:

suffix 后缀

题目大意:

就是给你两个链表,然后求他们的结尾有没有相同的结点,如果有就输出第一个相同的结点,输出他的地址.

如果没有就输出-1

思路如下:

用多个数组来做 data保存数据.next保存下一个指数.然后用一个time来计算每个地址出现的次数.

等下那个地址第一次出现了两次,那么他就是答案.

代码如下:

#include<iostream>
using namespace std;
int main(void) {
	int Add_1, Add_2, N,flag = 0;
	int temp, next[100005], time[100005] = { 0 };
	//for (int i = 0; i < 100005; ++i)	time[i] = 0;
	char date[100005];
	scanf("%d%d%d", &Add_1, &Add_2, &N);
	for (int i = 0; i < N; ++i) {
		scanf("%d ", &temp);
		scanf("%c%d", &date[temp],&next[temp]);
	}
	temp = Add_1;
	while (temp != -1) {
		time[temp]++;
		temp = next[temp];
	}
	temp = Add_2;
	while (temp != -1) {
		time[temp]++;
		if (time[temp] == 2) { 
			flag = temp;
			break;
		}
		temp = next[temp];
	}
	if (flag == 0)printf("-1");
	else printf("%05d", flag);
	return 0;
}

柳神的思路如下:

分析:用结构体数组存储,node[i]表示地址为i的结点,key表示值,next为下一个结点的地址,flag表示第一条链表有没有该结点
遍历第一条链表,将访问过的结点的flag都标记为true,当遍历第二条结点的时候,如果遇到了true的结点就输出并结束程序,没有遇到就输出-1

和俺的想法差不多

确实还是bool类型的更加方便一点.

柳神的代码如下:

#include <cstdio>
using namespace std;
struct NODE {
    char key;
    int next;
    bool flag;
}node[100000];
int main() {
    int s1, s2, n, a, b;
    scanf("%d%d%d", &s1, &s2, &n);
    char data;
    for(int i = 0; i < n; i++) {
        scanf("%d %c %d", &a, &data, &b);
        node[a] = {data, b, false};
    }
    for(int i = s1; i != -1; i = node[i].next)
        node[i].flag = true;
    for(int i = s2; i != -1; i = node[i].next) {
        if(node[i].flag == true) {
            printf("%05d", i);
            return 0;
        }
    }
    printf("-1");
    return 0;
}

如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗

相信我,你也能变成光.

在这里插入图片描述

如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值