F - Anniversary party(POJ - 2342 )

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5

题目大意:

某公司的员工参加一次聚会,给你N代表参加的人数,接下有N个数,第i个数代表第i个员工的快乐指数,

接下来输入L,K,代表K是L的直接上司,遇到0 0结束。现在每个员工都不希望和自己的直接上司一起参加,问参加这个聚会的最大快乐指数可以为多少?

本题为树形dp,不过本题对一个公司来说应该会有一个最大的上司,即不会存在两个或两个以上的最大上司。

AC代码:

#include <stdio.h>
#include <stdlib.h>
#define max(a,b) (a)>(b)?(a):(b)
#include <string.h>
int dp[6001][2];
int father[6001];
int visit[6001];//用来标记是否已经被访问
//全局变量初值默认为,所以不需要在进行初始化。
int n;//员工数目
void dfs(int node)
{
    visit[node]=1;//表示已经被访问了
    int i;
    for(i=1; i<=n; i++)
    {
        if(visit[i]!=1&&father[i]==node)
        {
            dfs(i);
            dp[node][1]+=dp[i][0];//上司去,则他的直接下属不能去。
            dp[node][0]+=max(dp[i][1],dp[i][0]);//上司不去,他的下属可以去,也可以不去
            //加上去或不去的最大兴奋值值
        }
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)//员工数目
    {
        int i;
        int root;//根节点
        for(i=1; i<=n; i++)
        {
            scanf("%d",&dp[i][1]);//重要程度
        }
        int staff,boss;
        while(scanf("%d %d",&staff,&boss),(staff+boss>0))
        {
            father[staff]=boss;
            root=boss;
        }
        while(father[root])
        {
            root=father[root];
        }
        dfs(root);
        printf("%d\n",max(dp[root][1],dp[root][0]));
    }
    return 0;
}


一道英文题,不过题目意思比较易懂,就是大家去参加一个聚会,但是员工和他的直系上属不想要一起参加,也就是说,上属去了,下属就不能去。上属不去,下属可去可不去。

两种情况,三种选择。

题目思路:先输入一个整数N,用来表示员工数目。定义dp[i][j]数组,i 表示第i个员工,j=1表示他出席,j=0即表示他不出席。

后面输入一行两个数分别为员工和他的下属,用一个Father[]数组储存对于员工的上司。root表示公司最大的BOSS(每个公司一定只有一位最大的BOSS,即树的根节点)

int staff,boss;
        while(scanf("%d %d",&staff,&boss),(staff+boss>0))
        {
            father[staff]=boss;
            root=boss;
        }
        while(father[root])//根节点父亲没有父亲结点,所以它的父亲结点没有赋值,仍为初值0
        {
            root=father[root];
        }

然后dfs根节点

void dfs(int node)
{
    visit[node]=1;//表示已经被访问了
    int i;
    for(i=1; i<=n; i++)
    {
        if(visit[i]!=1&&father[i]==node)
        {
            dfs(i);
            dp[node][1]+=dp[i][0];//上司去,则他的直接下属不能去。
            dp[node][0]+=max(dp[i][1],dp[i][0]);//上司不去,他的下属可以去,也可以不去
            //加上去或不去的最大兴奋值值
        }
    }
}

完整AC代码:(这道题仍存在时间复杂度较高的问题)

#include <stdio.h>
#include <stdlib.h>
#define max(a,b) (a)>(b)?(a):(b)
#include <string.h>
int dp[6001][2];
int father[6001];
int visit[6001];//用来标记是否已经被访问
//全局变量初值默认为,所以不需要在进行初始化。
int n;//员工数目
void dfs(int node)
{
    visit[node]=1;//表示已经被访问了
    int i;
    for(i=1; i<=n; i++)
    {
        if(visit[i]!=1&&father[i]==node)
        {
            dfs(i);
            dp[node][1]+=dp[i][0];//上司去,则他的直接下属不能去。
            dp[node][0]+=max(dp[i][1],dp[i][0]);//上司不去,他的下属可以去,也可以不去
            //加上去或不去的最大兴奋值值
        }
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)//员工数目
    {
        int i;
        int root;//根节点
        for(i=1; i<=n; i++)
        {
            scanf("%d",&dp[i][1]);//重要程度
        }
        int staff,boss;
        while(scanf("%d %d",&staff,&boss),(staff+boss>0))
        {
            father[staff]=boss;
            root=boss;
        }
        while(father[root])//根节点父亲没有父亲结点,所以它的父亲结点没有赋值,仍为初值0
        {
            root=father[root];
        }
        dfs(root);
        printf("%d\n",max(dp[root][1],dp[root][0]));
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎曼猜想·

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值