2016第三场多校联盟训练1010

Windows 10

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 786    Accepted Submission(s): 239


Problem Description
Long long ago, there was an old monk living on the top of a mountain. Recently, our old monk found the operating system of his computer was updating to windows 10 automatically and he even can't just stop it !!
With a peaceful heart, the old monk gradually accepted this reality because his favorite comic LoveLive doesn't depend on the OS. Today, like the past day, he opens bilibili and wants to watch it again. But he observes that the voice of his computer can be represented as dB and always be integer.  
Because he is old, he always needs 1 second to press a button. He found that if he wants to take up the voice, he only can add 1 dB in each second by pressing the up button. But when he wants to take down the voice, he can press the down button, and if the last second he presses the down button and the voice decrease x dB, then in this second, it will decrease 2 * x dB. But if the last second he chooses to have a rest or press the up button, in this second he can only decrease the voice by 1 dB.
Now, he wonders the minimal seconds he should take to adjust the voice from p dB to q dB. Please be careful, because of some strange reasons, the voice of his computer can larger than any dB but can't be less than 0 dB.
 


Input
First line contains a number   T  ( 1T300000 ),cases number.
Next T line,each line contains two numbers   p  and   q   (0p,q109)
 


Output
The minimal seconds he should take
 


Sample Input
  
  
2 1 5 7 3
 


Sample Output
  
  
4 4




http://acm.hdu.edu.cn/showproblem.php?pid=5802

问题概述:音响实际音量A,目标音量B,如果你一直按着up键,那么每秒音量会提升1点,如果你一直按着down

键,那么每秒音量会降低2^(t-1)点,如果你中途停下1s或者按了一下up键,那么t就会初始化为1,请问从起始音量

到目标音量至少要按多少秒?


每次都有两个抉择:

①一直按↓直到音量刚好小于等于目标音量,然后再一直按↑,注意按↑的时间要减去之前停顿的时间

②一直按↓到音量只要多按1s就会小于目标音量,停顿1s,继续按↓

DFS


#include<stdio.h>
#include<algorithm>
using namespace std;
int Sech(int S, int T, int step, int stop)
{
	int x, temp, sum;
	if(S==T) 
		return step;
	x = 1, sum = 0;
	while(S-x+1>T)
		x *= 2, sum++;
	if(S-x+1==T)
		return step+sum;
	temp = sum+max(0, T-max(0, S-x+1)-stop);
	return min(temp+step, Sech(S-x/2+1, T, step+sum, stop+1));
}

int main(void)
{
	int T, a, b;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%d%d", &a, &b);
		if(b>=a)
			printf("%d\n", b-a);
		else
			printf("%d\n", Sech(a, b, 0, 0));
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值