3036: 绿豆蛙的归宿
Time Limit: 2 Sec Memory Limit: 128 MBSubmit: 724 Solved: 511
[ Submit][ Status][ Discuss]
Description
随着新版百度空间的下线,Blog宠物绿豆蛙完成了它的使命,去寻找它新的归宿。
给出一个有向无环的连通图,起点为1终点为N,每条边都有一个长度。绿豆蛙从起点出发,走向终点。
到达每一个顶点时,如果有K条离开该点的道路,绿豆蛙可以选择任意一条道路离开该点,并且走向每条路的概率为 1/K 。
现在绿豆蛙想知道,从起点走到终点的所经过的路径总长度期望是多少?
Input
第一行: 两个整数 N M,代表图中有N个点、M条边
第二行到第 1+M 行: 每行3个整数 a b c,代表从a到b有一条长度为c的有向边
Output
从起点到终点路径总长度的期望值,四舍五入保留两位小数。
Sample Input
4 4
1 2 1
1 3 2
2 3 3
3 4 4
Sample Output
7.00
水题,从终点倒过来DP一下就OK了
#include<stdio.h>
#include<vector>
using namespace std;
typedef struct
{
int y;
int len;
}Road;
Road now;
vector<Road> G[100005];
int out[100005], vis[100005];
double dp[100005];
void Sech(int u)
{
int i, v;
vis[u] = 1;
for(i=0;i<G[u].size();i++)
{
v = G[u][i].y;
if(vis[v]==0)
Sech(v);
dp[u] += dp[v]+G[u][i].len;
}
if(out[u])
dp[u] /= out[u];
}
int main(void)
{
int n, m, i, x, y, len;
scanf("%d%d", &n, &m);
for(i=1;i<=m;i++)
{
scanf("%d%d%d", &x, &y, &len);
now.y = y, now.len = len;
out[x]++;
G[x].push_back(now);
}
Sech(1);
printf("%.2f\n", dp[1]);
return 0;
}