POJ 2566 Bound Found (尺取法)

Bound Found
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4436 Accepted: 1403 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Link


题意:N个数字组成的数列,K个值,找出数列中一段和的绝对值与K个值相差最小的,输出和的绝对值以及起点和终点。输入0 0 结束


思路:一般尺取法只适用单调数列(一般和值递增),该题使用了数列求和的思想,把数列的s都求出来,并使用结构体保存下标,对和进行排序,就可以完美适用尺取法,最后通过下标获取左右区间节点即可


Sample Input:

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0


Sample Output:

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

AC代码:


#include<cstdio>
#include<algorithm>
#include<cmath>
#define INF 2000000010
using namespace std;

const int maxn=100000 +500;

int a[maxn];

struct node{
    int v,id;
}sum[maxn];

bool cmp1(node a ,node b){
    return a.v<b.v;
}

int main(){
    int n,k;
    while(~scanf("%d%d",&n,&k)&&(k+n)){
        //if(n==0&&k==0) break;
        sum[0].v=0;
        sum[0].id=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            sum[i].v=sum[i-1].v+a[i];
            sum[i].id=i;
        }
        sort(sum,sum+n+1,cmp1);
        while(k--){
        int tag;
        scanf("%d",&tag);
        int l=0,r=1;
        int lid,rid;
        int ans=INF;
        int anssum;
        while(l<=n&&r<=n){
            int w=abs(sum[r].v-sum[l].v);
            int q=abs(tag-w);
            if(ans>q){
                ans=q;
                anssum=w;
                lid=sum[l].id;
                rid=sum[r].id;
            }
            if(w>tag) l++;
            else if(w<tag) r++;
            if(w==tag) break;
            if(l==r) r++;
        }
        if(lid>rid) swap(lid,rid);
        printf("%d %d %d\n",anssum,lid+1,rid);

        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值