hdu 1423 Greatest Common Increasing Subsequence(最长公共上升子序列dp)

16 篇文章 0 订阅
11 篇文章 0 订阅
Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2
 
solution:
dp[i][j]表示a[1...i]和b[1...j]的最长上升子序列中以b[j]结尾的最长的长度。
如果a[i]!=b[j],则dp[i][j]=dp[i-1][j];
如果a[i]==b[j],则dp[i][j]=max(dp[i][k]+1)其中k<j&&a[i]>b[k];

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[550][550], a[550], b[550];
int main()
{
    int t,n,m;
    scanf("%d", &t);
    while (t--)
    {
        memset(dp, 0, sizeof(dp));
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        scanf("%d", &m);
        for (int i = 1; i <= m; i++)
            scanf("%d", &b[i]);
        for (int i = 1; i <= n; i++)
        {
            int k = 0;
            for (int j = 1; j <= m; j++)
            {
                if (a[i] != b[j])dp[i][j] = dp[i - 1][j];
                if (a[i] > b[j] && dp[i][j] > dp[i][k])k = j;
                if (a[i] == b[j])
                    dp[i][j] = dp[i][k] + 1;
            }
        }
        int ans = 0;
        for (int i = 1; i <= m; i++)
            ans = max(ans, dp[n][i]);
        printf("%d\n", ans);
        if (t)printf("\n");
    }
    return 0;
}


 

 


                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值